部署presto报Presto requires Java 8u151+ (found 1.8.0_144)解决方案

安装presto的时候,报jdk版本不兼容的问题解决方案,提示最低需要java 8u151及以上版本

vim /data/presto/bin/launcher

export JAVA_HOME=/opt/jdk1.8.0_151
export PATH=$JAVA_HOME/bin:$PATH
java -version
exec "$(dirname "$0")/launcher.py" "$@" #以上代码一定要加到这一行的上面

wang@bigdata-presto-001:/data/presto$ ./bin/launcher start
java version "1.8.0_151"
Java(TM) SE Runtime Environment (build 1.8.0_151-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.151-b12, mixed mode)
Started as 16257

发表评论

相关文章