Poetry 1.2.0 发布,Python 依赖管理和打包工具

Poetry 1.2.0 已正式发布。在 2 年开发周期内,新版本包含许多变化、新特性和 Bugfix。

Poetry 是一款 Python 依赖管理和打包工具。

Poetry 1.2.0 发布,Python 依赖管理和打包工具

主要变化

  • 采用新的独立安装程序

旧版get-poetry.py安装脚本已替换为 install.python-poetry.org。安装程序现在是一个独立的项目,有自己的问题跟踪器。

新的安装程序包含以下改进:

  • 从 standard wheels 安装发行版,而不是特定于平台的特殊档案。因此可支持pipx和手动安装,并防止发行版需要使用较新的依赖版本。
  • 标准安装位置用于 Poetry 本身和poetryCLI 封装器。
  • 支持从本地路径或 Git 仓库(包括分支或提交等引用)执行安装。
  • 提供了修改指导$PATH,但用户的配置不会被自动化工具改变。
  • Poetry 将使用调用安装程序的 Python 解释器进行安装。
  # Linux, macOS, Windows (WSL)  $ curl -sSL https://install.python-poetry.org | python3 -    # Windows (Powershell)  (Invoke-WebRequest -Uri https://install.python-poetry.org -UseBasicParsing).Content | py -
  • 不再支持管理 Python 2.7 项目

Poetry 1.2 不再支持管理 Python 2.7 项目,原因包括:

  • 它增加了技术债,并减缓了 Poetry 的发展。
  • 项目有足够时间迁移到 Python 3。

如果用户仍依赖 Poetry 管理 Python 2.7 项目,可继续使用 Poetry 1.1 分支,但官方将不再维护。

  • 不再支持将 Python 2.7, 3.5 和 3.6 作为运行时环境

Poetry 1.2 放弃了对 Python 2.7、3.5 和 3.6 的运行时环境支持。在这些版本上运行 Poetry 现在未经测试且不受支持。此更改是关于安装和运行 Poetry 本身,Poetry 仍然支持管理需要 Python 3.5 和 3.6 以及较旧的 Python 3 版本的项目。

详情查看发布公告

展开阅读全文
发表评论

相关文章