GTK4 的 Broadway HTML5 后端即将回归 Ubuntu、Debian

在过去的十年里,从早期的 GTK3 时代开始,"Broadway" 后端就已诞生,它支持将 GTK 界面渲染到 HTML5 Web 浏览器中。不过除了用于演示和其他玩具级别的应用之外,这个 GTK HTML5 后端并没有被广泛使用,诸如 Ubuntu 和 Debian 发行版也没有为较新的 GTK4 提供 Broadway 支持。然而,在 Debian 和今年秋天发布的 Ubuntu 22.10 中,这种情况正在发生变化。

Ubuntu 21.10 和 22.04 LTS 没有提供对 GTK4 Broadway 后端的支持,不过 Ubuntu 21.04 提供了 gtk4-broadwayd。在 Debian 的上游,由于明显缺乏使用,他们禁用了它。当 GTK 4.4 被上传到存档时,备注写道:

请禁用 Broadway(HTML) 后端,因为目前还不清楚这在实践中是否被使用。如果我们现在禁用它,以后如果要求启用它就不会破坏 ABI,但如果我们现在启用它,我们就必须无限期地保持启用。

那么,谁在实际使用这个 GTK HTML5 后端呢?目前来看至少有几个用户,即时通讯应用 Pidgin 的开发者依靠 Broadway 代码来运行他们的单元测试。Cambalache 和 Deckard 也都在使用它。

GTK4 的 Broadway HTML5 后端即将回归 Ubuntu、Debian

▲ Cambalache

Cambalache 是用于 GTK 3/4 的快速应用程序开发 (RAD) 工具,采用 MVC 设计和数据模型优先方法。Deckard 则是一个基于 Web 的 Glade runner。

现在,GTK4 HTML5 Broadway 支持不足的问题已在 Debian 上游得到解决,并且在即将推出的 Ubuntu 22.10 中也得到了解决。早在去年10月,就有一份关于缺乏 Broadway 支持从而影响 Cambalache 的错误报告

展开阅读全文
发表评论

相关文章