Ubuntu 22.10 将禁用 GNOME 43 新功能

众所周知,Ubuntu 目前所使用的桌面环境为 GNOME,因此 Ubuntu 也具备了很多 GNOME 的特性和功能。在 GNOME 43 中,有一个新的 "Device Security"(设备安全)面板,可以告诉用户目前设备的安全状态。但是在即将于 10 月份推出的 Ubuntu 22.10 中,你可能并不会看到这个功能的身影。

Ubuntu 22.10 将禁用 GNOME 43 新功能

在一份开发者近日提交的错误报告中,开发者表示新的 Device Security 功能目前令人感到困惑,并且毫无用处。

Ubuntu 22.10 将禁用 GNOME 43 新功能

开发者 Jeremy Bicha 表示:

默认的 Ubuntu 安装只能提供 "Security Level 1" 的安全级别,而最高级别是 "Security Level 3"。在 Device Security 界面中,Ubuntu 用户无法通过任何操作来获得更高的安全级别。

因为 Ubuntu 目前并不支持这样的操作,所以用户如果试图让系统达到更高的安全级别,我认为他们可能会破坏系统。

综上所述,我认为我们应该隐藏/禁用 Ubuntu 22.10 的这个界面。我们可以在未来的版本中努力为 Ubuntu 更好地整合这个功能。

Ubuntu 22.10 将禁用 GNOME 43 新功能

通常来说,这样一个能够统一查看设备安全等级的界面除了向用户展示目前的安全状况,还应该向用户展示可以怎么做来提高设备安全性。但 Device Security 中没有任何信息或背景说明每个要求对用户意味着什么,也没有提供任何细节说明如何能解决这些问题并 "提升" 设备安全等级。

对用户来说,当他们看到这些红色警示符号后又无法做出什么改变时,反而会认为操作系统本身不够安全,或者设备已经被恶意软件劫持导致无法提升设备安全性。甚者可能会考虑将系统更换成 Windows。

Canonical 的安全技术负责人 Marc Deslauriers 在报告中回复道:

如果普通用户不能从 GUI 本身轻松解决其中列出的问题,我认为在设置应用程序中显示这些问题是不合适的。

不过值得注意的是,GNOME 43 目前还处于测试阶段,开发人员还可以在下个月 GNOME 43 最终稳定版本发布之前调整这个功能。目前时间紧迫,GNOME 不一定能够提供一键修复的功能,但至少可以为用户设备可能存在的安全问题添加更多解释和详细信息。

展开阅读全文
发表评论

相关文章